CatBoost for Apache Spark installation

Requirements

  • Linux or macOS. Windows support in progress.
  • Apache Spark 2.3 - 3.0
  • Scala 2.11 or 2.12

Choose installation method

It is generally recommended to use stable releases available as Maven artifacts from Maven central:

You can also build from source using Maven.